WordPress Important Update (2.3.2)

wordpress.jpgWordPress just released an update that fixes a bug that could expose your draft posts. The update also suppresses some error messages that can give away information about your database table structure and limits and stops some information leaks in the XML-RPC and APP implementations. I have seen these error messages from orangeinks and some other blogs. The codes are there for everyone to see. I you’re using WordPress as a hosted blog platform, it is strongly suggested that you upgrade now to protect your blog from the said disclosures.

WordPress also added a little bonus of allowing you to define a custom DB error page.

Place your custom template at wp-content/db-error.php. If WP has a problem connecting to your database, this page will displayed rather than the default error message.

To help you with the upgrade, just follow the instructions posted here. And remember guys, backup your files.

3 Comments on “WordPress Important Update (2.3.2)

  1. I upgraded one of my sites . . . Now I can’t modify the categories. I delete them and when I refresh the page, they’re back! I won’t be upgrading any other sites until that problem with this latest upgrade is resolved!

  2. JHS: Sorry to hear about the problem that you have encountered. I was hesitant at first to upgrade because of the posts I read about the dangers of upgrading wordpress especially on Godaddy. I just followed the procedure and went on with it and it worked out fine. No errors. I disabled all the plugins first then I copied all the files except the wp-content folder. You might want to try to Visit the upgrade page. It will be at a URL like http://example.com/wordpress/wp-admin/upgrade.php. This updates your database to be compatible with the latest code.

Leave a Reply

Your email address will not be published. Required fields are marked *

*